Moonshine: Now with Ruby 2.1

Written By : Bryan Traywick

We are happy to announce that Moonshine now officially supports Ruby 2.1. This update has been several months in the making as we were waiting for upstream packages to be updated for Ruby 2.1.

We have tested Ruby 2.1 thoroughly and any applications using Ruby 2.0 should be able to upgrade to Ruby 2.1 with little issue.

New Deploy

Make sure your Ruby version in config/moonshine.yml is set to src21 or src21 (for Ruby 2.1 + the railsexpress patches).

Upgrading

Upgrading your existing Moonshine application to Ruby 2.1 is simple enough, assuming it is working locally on your development machine on Ruby 2.1.

First, update your version of Moonshine:

# Rails 2
$ ./script/plugin install git://github.com/railsmachine/moonshine.git --force
# Rails 3
$ ./script/rails plugin install git://github.com/railsmachine/moonshine.git --force
# Rails 4
$ plugger install git://github.com/railsmachine/moonshine.git --force

Next, update your Ruby version in the Moonshine config:

# config/moonshine.yml
:ruby: src21

Now, upgrade Ruby:

$ cap ruby:upgrade

Finally, re-deploy to make sure everything is up-to-date:

$ cap deploy

We recommend anyone performing this upgrade to do so on their staging server first just to make sure there are no show-stoppers in production.

Note

If you are using God to manage services on your servers then you will also need to ensure that you are using version 0.13.3 or greater. If you are using the Moonshine God plugin, then update the plugin to the latest version:

# Rails 2
$ ./script/plugin install git://github.com/railsmachine/moonshine_god.git --force
# Rails 3
$ ./script/rails plugin install git://github.com/railsmachine/moonshine_god.git --force
# Rails 4
$ plugger install git://github.com/railsmachine/moonshine_god.git --force

Going Forward

If you encounter any issues with Moonshine and Ruby 2.1, or any of the Moonshine plugins we provide and Ruby 2.1, please file issues on GitHub.